Yes. Edwiser Forms is compatible with Moodle 3.6 + versions.